题目

Calculate $a + b$ and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers $a$ and $b$ where $-10^6 \le a, b \le 10^6$ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of $a$ and $b$ in one line. The sum must be written in the standard format.

Sample Input:

1
-1000000 9

Sample Output:

1
-999,991

思路

2018/1/5更新0:重要参考链接 Stack overflow有一个帖子专门讨论如何做这个事情,我自己想到的三个也都是问题里几个高票答案的方法,大家可以学习一下。

两个要点:

  • 两数和为0时要输出0;
  • 注意逗号的输出位置,如不要在数字前面和后面有输出

2018/1/5更新1:

又看了一遍题,总感觉之前的代码太繁琐,就改了一个方法,使用字符串处理。 得到a和b后,将两者之和输入到一个字符串中去,使用sprintf函数。 只需要从后向前,每三个数字判断一下是否需要加逗号即可。

2018/1/5更新2:

还有一种更省事的方法,甚至C语言里都有直接的方法处理这种事情。那就是头文件,这个头文件可以处理不同地区或者语言的输出方式,其中就有对数字的处理。具体细节可查看相关资料,代码放在下面

1
2
3
4
5
6
7
8
9
#include <stdio.h>
#include <locale.h>

int main(void)
{
    setlocale(LC_NUMERIC, "");
    printf("%'d\n", 1123456789);
    return 0;
}

更新前的代码

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
#include <stdio.h>
#include <string.h>

int main()
{
	int a, b, pos;
	char num[11];

	scanf("%d%d", &a, &b);
	sprintf(num, "%d", a + b);

	for (pos = strlen(num) - 3; pos > 0 && num[pos - 1] != '-'; pos -= 3) {
		memmove(num + pos + 1, num + pos, strlen(num) - pos + 1);
		num[pos] = ',';
	}

	puts(num);
	return 0;
}