PAT Advanced 1009. Product of Polynomials (25) (C语言实现)
题目
This time, you are supposed to find $A\times B$ where $A$ and $B$ are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
$K$ $N_1$ $a_{N_1}$ $N_2$ $a_{N_2}$ … $N_K$ $a_{N_K}$
where $K$ is the number of nonzero terms in the polynomial, $N_i$ and $a_{N_i}$ ( $i=1, 2, \cdots , K$ ) are the exponents and coefficients, respectively. It is given that $1\le K \le 10$ , $0 \le N_K < \cdots < N_2 < N_1 \le 1000$ .
Output Specification:
For each test case you should output the product of $A$ and $B$ in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
1
2
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
1
3 3 3.6 2 6.0 1 1.6
思路
为了思路简单,就直接开大数组遍历了,没有什么难点
代码
Github最新代码,欢迎交流
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include <stdio.h>
int main()
{
int N, exp, count = 0;
float coef, A[1001] = {0}, B[1001] = {0}, MUL[2001] = {0};
scanf("%d", &N);
while (N--) {
scanf("%d %f", &exp, &coef);
A[exp] = coef;
}
scanf("%d", &N);
while (N--) {
scanf("%d %f", &exp, &coef);
B[exp] = coef;
}
for (int i = 0; i < 1001; i++)
for (int j = 0; j < 1001; j++)
MUL[i + j] += A[i] * B[j];
for (int i = 0; i < 2001; i++)
if (MUL[i]) count++;
printf("%d", count);
for (int i = 2000; i >= 0; i--)
if (MUL[i])
printf(" %d %.1f", i, MUL[i]);
return 0;
}