题目

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting $city_1$ - $city_2$ and $city_1$ - $city_3$ . Then if $city_1$ is occupied by the enemy, we must have 1 highway repaired, that is the highway $city_2$ - $city_3$ .

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers $N$ ( $<1000$ ), $M$ and $K$ , which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then $M$ lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to $N$ . Finally there is a line containing $K$ numbers, which represent the cities we concern.

Output Specification:

For each of the $K$ cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

1
2
3
4
3 2 3
1 2
1 3
1 2 3

Sample Output:

1
2
3
1
0
0

思路

题目即要求我们计算这些城市有几个内部相连的部分。

思路是对这些城市和公路组成的图进行多次遍历,直至所有城市都被遍历位置,遍历次数减1即为需要修复的公路数量。

具体遍历时,逐一城市进行一个更高层的循环,跳过已遍历过的即可。

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <stdio.h>

#define MAX 1000

void DFS(int v, int known[], int G[][MAX])
{
	known[v] = 1;
	for (int i = 0; i < MAX; i++)
		if ((G[v][i] || G[i][v]) && !known[i])
			DFS(i, known, G);
}

int main()
{
	int N, M, K;
	scanf("%d %d %d", &N, &M, &K);

	int Graph[MAX][MAX] = {{0}};

	int city1, city2;
	for (int i = 0; i < M; i++) {
		scanf("%d %d", &city1, &city2);
		Graph[city1][city2] = 1;
	}

	for (int i = 0; i < K; i++) {
		int known[MAX] = {0}, lostcity, count = 0;
		scanf("%d", &lostcity);

		known[lostcity] = 1;
		for (int i = 1; i <= N; i++)
			if (!known[i]) {
				DFS(i, known, Graph);
				count++;
			}
		printf("%d\n", count - 1);
	}
}