PAT Advanced 1027. Colors in Mars (20) (C语言实现)
题目
People in Mars represent the colors in their computers in a similar way as the
Earth people. That is, a color is represented by a 6-digit number, where the
first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2
digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C)
instead of 16. Now given a color in three decimal numbers (each between 0 and
168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following
format: first output #
, then followed by a 6-digit number where all the
English characters must be upper-cased. If a single color is only 1-digit
long, you must print a 0
to its left.
Sample Input:
1
15 43 71
Sample Output:
1
#123456
思路
很简单的一道题,13进制的转换
代码
Github最新代码,欢迎交流
1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <stdio.h>
int main()
{
int n, DIGITS = 3;
char convert[] = "0123456789ABC";
printf("#");
for (int i = 0; i < DIGITS; i++) {
scanf("%d", &n);
printf("%c%c", convert[n / 13], convert[n % 13]);
}
return 0;
}