题目

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [ $1, 10^4$ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer $N$ ( $\le 10^5$ ) and then followed by $N$ bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

1
7 5 31 5 88 67 88 17

Sample Output 1:

1
31

Sample Input 2:

1
5 888 666 666 888 888

Sample Output 2:

1
None

思路

输出第一个独特的数字。

很简单,唯一要注意的是这里的第一个是指出现顺序。因此我实现中用了两个大数组。

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include <stdio.h>

int main()
{
	int N, counts[10001] = {0}, bets[100000] = {0};

	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		scanf("%d", bets + i);
		counts[bets[i]]++;
	}

	for (int i = 0; i < N; i++)
		if (counts[bets[i]] == 1) {
			printf("%d", bets[i]);
			return 0;
		}

	printf("None");
	return 0;
}