题目

The task is really simple: given $N$ exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer $N$ (in [ $3, 10^5$ ]), followed by $N$ integer distances $D_1$ $D_2$ $\cdots$ $D_N$ , where $D_i$ is the distance between the $i$ -th and the $(i+1)$ -st exits, and $D_N$ is between the $N$ -th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer $M$ ( $\le 10^4$ ), with $M$ lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to $N$ . It is guaranteed that the total round trip distance is no more than $10^7$ .

Output Specification:

For each test case, print your results in $M$ lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

1
2
3
4
5
5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

1
2
3
3
10
7

思路

题目给出一个环形线路上各出口之间的距离,要求任意两出口之间的最短距离。

将数据记录为任何一点到第一个出口之间的距离,更省时间。注意有两个方向可以选择,其中一个小于一半总长度。

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include <stdio.h>

int main()
{
	int N, M, start, end, d, D[100001] = {0};

	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		scanf("%d", D + i + 1);
		/* record the distance between the current and the first exits */
		D[i + 1] += D[i];
	}

	scanf("%d", &M);
	for (int i = 0; i < M; i++) {
		scanf("%d %d", &start, &end);
		d = --start > --end ? D[start] - D[end] : D[end] - D[start];
		/* if the distance is more than half total length, the other direction will be shorter */
		printf("%d\n", d * 2 > D[N] ? D[N] - d : d);
	}

	return 0;
}