题目

Given a stack which can keep $M$ numbers at most. Push $N$ numbers in the order of 1, 2, 3, …, $N$ and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if $M$ is 5 and $N$ is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): $M$ (the maximum capacity of the stack), $N$ (the length of push sequence), and $K$ (the number of pop sequences to be checked). Then $K$ lines follow, each contains a pop sequence of $N$ numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

1
2
3
4
5
6
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

1
2
3
4
5
YES
NO
NO
YES
NO

思路

验证一个序列是否可以用堆栈生成。

我的方法是模拟堆栈的操作,看能否实现所给序列的输出。这是比较直观的思路,并且效率也可以,不知道有没有其它的思路。

(目前不是很满意代码的实现,感觉逻辑比较罗嗦,有重复代码,不知能不能简化)

一个极其粗糙的伪代码(细致的需要十几行,直接看后面真代码吧)就是:

1
2
3
4
5
直至(得到所给序列)或者(无法再入栈):
    如果栈顶与所需数字相同:
        出栈,读下一个所需数字
    否则入栈
根据出栈数量判断是否成功

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include <stdio.h>

int main()
{
	char c;
	int M, N, K, stack[7] = {0}, top, pushed, popped, wanted;

	scanf("%d %d %d", &M, &N, &K);
	for (int i = 0; i < K; i++) {
		top = -1;
		pushed = 0;
		popped = 0;
		/* push */
		stack[++top] = ++pushed;
		scanf("%d", &wanted);
		for ( ; ; ) {
			if (top != -1 && stack[top] == wanted) {
				/* pop */
				stack[top--] = 0;
				popped++;
				/* read */
				if (popped < N) {
						scanf("%d", &wanted);
						continue;
				}
				else
						break;
			}
			/* push */
			if (pushed < N && top < M - 1)
				stack[++top] = ++pushed;
			else
				break;
		}
		printf("%s\n", popped < N ? "NO" : "YES");
		while ((c = getchar()) != EOF && c != '\n');
	}

	return 0;
}