题目

本题要求计算 $A/B$ ,其中 $A$ 是不超过 1000 位的正整数, $B$ 是 1 位正整数。你需要输出商数 $Q$ 和余数 $R$ ,使得 $A = B \times Q + R$ 成立。

输入格式:

输入在一行中依次给出 $A$ 和 $B$ ,中间以 1 空格分隔。

输出格式:

在一行中依次输出 $Q$ 和 $R$ ,中间以 1 空格分隔。

输入样例:

1
123456789050987654321 7

输出样例:

1
17636684150141093474 3

思路

就是模拟一个手算除法的过程。

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <stdio.h>

/* read 2 digits from highest digit of A, do manual division, get the quotient
 and remainder. Read one more digit, combine this with the last remainder to
get a new 2-digits number. Do this until read to the end of A */

int main()
{
	int B;
	char A[1001], *p = A;
	scanf("%s %d", A, &B);

	/* the results are stored in A and B instead of printed out on-the-fly */
	int twodigit, remainder = 0;
	for (int i = 0; A[i]; i ++) {
		twodigit = remainder * 10 + (A[i] - '0');
		A[i] = twodigit / B + '0';
		remainder = twodigit % B;
	}
	B = remainder;

	/* print */
	if (A[0] == '0' && A[1] != '\0') p++;
	printf("%s %d", p, B);

	return 0;
}