题目

本题要求编写程序,计算 2 个有理数的和、差、积、商。

输入格式:

输入在一行中按照 a1/b1 a2/b2 的格式给出两个分数形式的有理数,其中分子和分母全是整型范围内的整数,负号只可能出现在分子前,分母不为 0。

输出格式:

分别在 4 行中按照 有理数1 运算符 有理数2 = 结果 的格式顺序输出 2 个有理数的和、差、积、商。注意输出的每个有理数必须是该有理数的最简形式 k a/b,其中 k 是整数部分,a/b 是最简分数部分;若为负数,则须加括号;若除法分母为 0,则输出 Inf。题目保证正确的输出中没有超过整型范围的整数。

输入样例 1:

1
2/3 -4/2

输出样例 1:

1
2
3
4
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

输入样例 2:

1
5/3 0/6

输出样例 2:

1
2
3
4
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

思路

这道题的注意点就是分数的约分和表示。

  • 题目限定了输入输出都不超过整型范围,那么当我们计算两个分数的加减乘除时,分子分母就应该不超过长整形范围:
    • 极限情况就是两者之和/之差的分子为 $a_1\times b_2+a_2\times b_1\le 2\times (2^{31}-1)^2\lt2^{63}-1$
  • 输出形式共有3种:
    • 假分数,输出整数部分和真分数部分;
    • 真分数,只输出真分数部分;
    • 整数,只输出整数部分。
  • 在判断输出的正负号时,如果分子分母还没有约分,那么小心使用两者之积来判断符号,因为已经溢出长整形范围。

代码

Github最新代码,欢迎交流

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
#include <stdio.h>

/* Both parameters take positive value */
long calcgcd(long a, long b)
{
	long r;
	while ((r = a % b)) {
		a = b;
		b = r;
	}
	return b;
}

/* print a fraction number, giving the numerator and dominator */
void printfrac(long n, long d)
{
	if (d == 0) {
		printf("Inf");
		return;
	}

	/* record the sign and make them positive */
	int inegative = 1;
	if (n < 0) {
		n = -n;
		inegative *= -1;
	}
	if (d < 0) {
		d = -d;
		inegative *= -1;
	}

	/* reduce the fraction */
	long gcd = calcgcd(n, d);
	n /= gcd;
	d /= gcd;

	/* print */
	if (inegative == -1)
		printf("(-");

	if (n / d && n % d) /* mixed fractions */
		printf("%ld %ld/%ld", n / d, n % d, d);
	else if (n % d)     /* proper fractions */
		printf("%ld/%ld", n % d, d);
	else                /* integers */
		printf("%ld", n / d);

	if (inegative == -1)
		printf(")");
}

int main()
{
	long a1, b1, a2, b2;
	scanf("%ld/%ld %ld/%ld", &a1, &b1, &a2, &b2);

	char op[4] = {'+', '-', '*', '/'};
	for (int i = 0; i < 4; i++) {
		printfrac(a1, b1);
		printf(" %c ", op[i]);
		printfrac(a2, b2);
		printf(" = ");
		switch(op[i]) {
		case '+':
			printfrac(a1 * b2 + a2 * b1, b1 * b2);
			break;
		case '-':
			printfrac(a1 * b2 - a2 * b1, b1 * b2);
			break;
		case '*':
			printfrac(a1 * a2, b1 * b2);
			break;
		case '/':
			printfrac(a1 * b2, b1 * a2);
			break;
		}
		printf("\n");
	}

	return 0;
}