PAT Basic 1054. 求平均值 (20) (C语言实现)
题目
本题的基本要求非常简单:给定 $N$ 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [ $-1000, 1000$ ] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 $N$ ( $\le 100$ )。随后一行给出 $N$ 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The
average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2
位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is
Y
。
输入样例 1:
1
2
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
1
2
3
4
5
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
1
2
2
aaa -9999
输出样例 2:
1
2
3
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
思路
先说说输入: 我们不清楚题目会给出多长的非法输入,因此为了防止溢出,我们应该选择一个安全的方式应对这种情况。
我的方法是先确定合法数字的最长长度:8个字符,那么我们每次就先只读8个字符。如果输入流(stdin
)中的下一个字符不是空白字符,那么这个数就绝对非法;如果是空白字符的话,再继续讨论接下来的问题。
(这个问题几乎网上所有AC的方法都是用的一个大数组来读取,应该是PAT对这一点没有严格检查(要是有上千字符的输入就不行了)。我只是出于健壮性考虑,照顾到了这一点)
(通过率0.19的题我一次AC了,先让我激动一会儿 \(≧▽≦)/
)
代码实现
- 读取8个字符,使用了
scanf("%8s", str)
,就是读到空白字符或者8个字符。 - 判断是否是浮点,使用了函数
strtod(const char *, char **)
,这个函数的第二个参数是一个指针的地址,用来使该指针指向未用于转换的第一个字符,我们可以根据这个指针是否为NULL
来判断这个字符串是否为浮点。 (e.g. 如第一个参数传入字符串2.3.4,第二个参数这个指针会指向第二个小数点) - 精度,找到小数点(有的话)的位置,看它距字符串结尾有几个字符就好了,不能大于3个。
P.S. 在网上看到了结合使用sscanf和sprintf的方法,相当的巧妙。忘记了在哪里,读者可自行查找,或尝试自己去实现。
代码
Github最新代码,欢迎交流
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <ctype.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
int count = 0, N;
double f, sum = 0;
/* Maxium scenario: -1000.00. So just need to read 8 chars(+ '\0' = 9) */
char s[9], *pEnd, *pDot, c;
scanf("%d", &N);
for (int i = 0; i < N; i++) {
scanf("%8s", s); /* Just read up to 8 chars */
c = ungetc(getchar(), stdin); /* Read next char and push back */
f = strtod(s, &pEnd); /* pEnd -> converted floating number */
pDot = strchr(s, '.'); /* pDot -> (first) decimal point */
if ((!isspace(c) && c != EOF) /* string too long */
|| *pEnd /* not floating number */
|| (f > 1000 || f < -1000) /* out of range */
|| (pDot && pDot - s < strlen(s) - 3)) { /* precision too high */
printf("ERROR: %s", s);
/* this can avoid overflow (we don't know how long input is) */
while (!isspace(c = getchar()) && c != EOF) putchar(c);
printf(" is not a legal number\n");
} else { /* legel number */
count++;
sum += f;
}
}
if (count == 0)
printf("The average of 0 numbers is Undefined\n");
if (count == 1)
printf("The average of 1 number is %.2lf", sum);
if (count >= 2)
printf("The average of %d numbers is %.2lf", count, sum / count);
return 0;
}